It appears that my 3.5.x license codes work for 3.6.1a. I have a University
license.

Am I lucky, or is the activation the same.