I'm trying to connect to a web service endpoint with the SOAP driver but
I do not need to HTTP authorization header to connect as we are
performing authentication by placing the uname and password in the soap
header. I have removed the authentication ID and authentication password
fields from the driver properties, but when the driver attempts to
connect it is still adding the HTTP authorization header. See trace
below:

[12/31/1969 19:00:00.183] DRIVER STRIVER: Value of boolean flag
'remove-existing' is : false
[01/01/1970 0:41:20.186] DRIVER STRIVER:
HTTPSubscriberTransport.send()
[12/31/1969 19:00:04.187] DRIVER STRIVER: Preparing HTTP POST
connection to http://10.157.44.23:7001/ENDPOINT/MRWSUserAccess
[10/07/1974 21:10:16.189] DRIVER STRIVER: Setting the following HTTP
request properties:
[12/31/1969 19:00:00.190] DRIVER STRIVER: Authorization:
<credentials suppressed>
[12/31/1969 19:00:00.191] DRIVER STRIVER: SOAPAction:
#batchRequest
[12/31/1969 23:34:12.193] DRIVER STRIVER: Content-Type: text/xml;
charset=utf-8
[12/31/1969 19:00:00.205] DRIVER STRIVER: Did HTTP POST with 1281
bytes of data to http://10.157.44.23:7001/ENDPOINT/MRWSUserAccess
[12/31/1969 19:00:00.223] DRIVER STRIVER: Response code and message:
401 Unauthorized
[12/31/1969 19:00:00.223] DRIVER STRIVER: The following bytes (which
are base64 encoded) were received as a response to our request on the
subscriber channel. They cannot be converted to XML:
[03/01/1970 17:10:36.226] DRIVER STRIVER:
PCFET0NUWVBFIEhUTUwgUFVCTElDICItLy9XM0MvL0RURCBIVE 1MIDQuMCBEcmFmdC8vRU4iPgo8SFRNTD4KPEhFQUQ+CjxUSVRM RT5FcnJvciA0MDEtLVVuYXV0aG9yaXplZDwvVElUTEU+CjxNRV RBIE5BTUU9IkdFTkVSQVRPUiIgQ09OVEVOVD0iV2ViTG9naWMg U2VydmVyIj4KPC9IRUFEPgo8Qk9EWSBiZ2NvbG9yPSJ3aGl0ZS I+CjxGT05UIEZBQ0U9SGVsdmV0aWNhPjxCUiBDTEVBUj1hbGw+ CjxUQUJMRSBib3JkZXI9MCBjZWxsc3BhY2luZz01PjxUUj48VE Q+PEJSIENMRUFSPWFsbD4KPEZPTlQgRkFDRT0iSGVsdmV0aWNh IiBDT0xPUj0iYmxhY2siIFNJWkU9IjMiPjxIMj5FcnJvciA0MD EtLVVuYXV0aG9yaXplZDwvSDI+CjwvRk9OVD48L1REPjwvVFI+ CjwvVEFCTEU+CjxUQUJMRSBib3JkZXI9MCB3aWR0aD0xMDAlIG NlbGxwYWRkaW5nPTEwPjxUUj48VEQgVkFMSUdOPXRvcCBXSURU SD0xMDAlIEJHQ09MT1I9d2hpdGU+PEZPTlQgRkFDRT0iQ291cm llciBOZXciPjxGT05UIEZBQ0U9IkhlbHZldGljYSIgU0laRT0i MyI+PEgzPkZyb20gUkZDIDIwNjggPGk+SHlwZXJ0ZXh0IFRyYW 5zZmVyIFByb3RvY29sIC0tIEhUVFAvMS4xPC9pPjo8L0gzPgo8 L0ZPTlQ+PEZPTlQgRkFDRT0iSGVsdmV0aWNhIiBTSVpFPSIzIj 48SDQ+MTAuNC4yIDQwMSBVbmF1dGhvcml6ZWQ8L0g0Pgo8L0ZP TlQ+PFA+PEZPTlQgRkFDRT0iQ291cmllciBOZXciPlRoZSByZX F1ZXN0IHJlcXVpcmVzIHVzZXIgYXV0aGVudGljYXRpb24uIFRo ZSByZXNwb25zZSBNVVNUIGluY2x1ZGUgYSBXV1ctQXV0aGVudG ljYXRlIGhlYWRlciBmaWVsZCAoc2VjdGlvbiAxNC40NikgY29u dGFpbmluZyBhIGNoYWxsZW5nZSBhcHBsaWNhYmxlIHRvIHRoZS ByZXF1ZXN0ZWQgcmVzb3VyY2UuIFRoZSBjbGllbnQgTUFZIHJl cGVhdCB0aGUgcmVxdWVzdCB3aXRoIGEgc3VpdGFibGUgQXV0aG 9yaXphdGlvbiBoZWFkZXIgZmllbGQgKHNlY3Rpb24gMTQuOCku IElmIHRoZSByZXF1ZXN0IGFscmVhZHkgaW5jbHVkZWQgQXV0aG 9yaXphdGlvbiBjcmVkZW50aWFscywgdGhlbiB0aGUgNDAxIHJl c3BvbnNlIGluZGljYXRlcyB0aGF0IGF1dGhvcml6YXRpb24gaG FzIGJlZW4gcmVmdXNlZCBmb3IgdGhvc2UgY3JlZGVudGlhbHMu IElmIHRoZSA0MDEgcmVzcG9uc2UgY29udGFpbnMgdGhlIHNhbW UgY2hhbGxlbmdlIGFzIHRoZSBwcmlvciByZXNwb25zZSwgYW5k IHRoZSB1c2VyIGFnZW50IGhhcyBhbHJlYWR5IGF0dGVtcHRlZC BhdXRoZW50aWNhdGlvbiBhdCBsZWFzdCBvbmNlLCB0aGVuIHRo ZSB1c2VyIFNIT1VMRCB
[12/31/1969 19:00:00.226]
iZSBwcmVzZW50ZWQgdGhlIGVudGl0eSB0aGF0IHdhcyBnaXZlb iBpbiB0aGUgcmVzcG9uc2UsIHNpbmNlIHRoYXQgZW50aXR5IE1 BWSBpbmNsdWRlIHJlbGV2YW50IGRpYWdub3N0aWMgaW5mb3JtY XRpb24uIEhUVFAgYWNjZXNzIGF1dGhlbnRpY2F0aW9uIGlzIGV 4cGxhaW5lZCBpbiBzZWN0aW9uIDExLjwvRk9OVD48L1A+CjwvR k9OVD48L1REPjwvVFI+CjwvVEFCTEU+Cgo8L0JPRFk+CjwvSFR NTD4K
[12/31/1969 19:00:00.240] DRIVER ST:SubscriptionShim.execute()
returned:
[01/25/1971 16:15:27.241] DRIVER ST:

I was able to duplicate the above "401 unauthorized" error by adding
the HTTP Authorization to the document through SOAP UI. If i send the
same document through SOAP UI without the authorization header, it works
just fine. Any idea why the driver would be adding this? Thanks in
advance for any help!

Thanks,
B


--
bjohnsonacn
------------------------------------------------------------------------
bjohnsonacn's Profile: http://forums.novell.com/member.php?userid=43213
View this thread: http://forums.novell.com/showthread.php?t=385166