We will be updating our IDM environment soon. In our plans, we will go
to 2008R2 DC's.

We are running Exchange 2003-yeah, yeah, I know Groupwise rocks...and
I've now seen in posts that Exchange 2007 will not install on 2008R2. I
guess I could use 2008 SP2, but if there's a remote possibility of IDM
3.6.1 supporting 2010, I'd be willing to hold out.

What do you think?
Thank,
Mr Mister