We're trying to move a driver from an old version of IDM and having no
luck. Since the issue appears to be the Oracle connection we've created
a barebones JDBC driver with connection to an Oracle Db using the
wizard.

Log gives us:


[06/30/09 11:54:17.712]:JDBCtest2 PT:BEGIN Get database properties.
[06/30/09 11:54:17.716]:JDBCtest2 PT: Database name: Oracle
[06/30/09 11:54:17.717]:JDBCtest2 PT: Database version: Oracle
Database 10g Enterprise Edition Release 10.2.0.4.0 - 64bit Production
[06/30/09 11:54:17.719]:JDBCtest2 PT: JDBC driver name: Oracle JDBC
driver
[06/30/09 11:54:17.720]:JDBCtest2 PT: JDBC driver version:
10.2.0.4.0
[06/30/09 11:54:17.728]:JDBCtest2 PT: JDBC driver major version: 10
[06/30/09 11:54:17.734]:JDBCtest2 PT: JDBC driver minor version: 2

.....

[06/30/09 11:54:16.007]:JDBCTEST2 ST: SUPPORTED TABLE TYPES: []
[06/30/09 11:54:16.008]:JDBCTEST2 ST: SUPPORTED VIEW TYPES: []
[06/30/09 11:54:16.009]:JDBCTEST2 ST: SUPPORTS VIEWS: FALSE

-***** not sure why "Supports views" is false! *******-


[06/30/09 11:54:16.075]:JDBCtest2 ST:END Get database properties.
[06/30/09 11:54:16.077]:JDBCtest2 ST:BEGIN Get table metadata.
[06/30/09 11:54:16.078]:JDBCTEST2 ST: SEARCHING FOR TABLE/VIEW 'NAME
REMOVED' USING TYPE FILTER [].
-
The above filter is presumably the issue (see SQL log later on)-

[06/30/09 11:54:16.111]:JDBCtest2 ST: No match.
....
<status level="error" type="driver-general">
<description>Table/view 'NAME REMOVED' is undefined or the driver lacks
the necessary privileges to see it.</description>


USING SQLPLUS THE ORACLE ACCOUNT CAN ACCESS THE VIEW/TABLES BOTH
LOCALLY AND REMOTELY, SO PERMISSIONS DOESN'T SEEN TO BE THE ISSUE.


The only clue we can find is in the Oracle logs where we get:

SELECT NULL AS table_cat,
o.owner AS table_schem,
o.object_name AS table_name,
o.object_type AS table_type,
NULL AS remarks>
FROM all_objects o
WHERE o.owner LIKE :1 ESCAPE '/'
AND o.object_name LIKE :2 ESCAPE '/'
AND O.OBJECT_TYPE IN ('XXX')
ORDER BY table_type, table_schem, table_name

I suspect the o.object_type line is the issue since I would have
thought "TABLE" or "VIEW" should appear

Any help or pointers much appreciated.


Details:

Linux AS5
IDM 3.6
/opt/novell/eDirectory/lib/dirxml/classes contains both : ojdbc14.jar
& orai18n.jar
JVM 1.4


--
eame0002
------------------------------------------------------------------------
eame0002's Profile: http://forums.novell.com/member.php?userid=38726
View this thread: http://forums.novell.com/showthread.php?t=378455