hi, engine lost connection with a driver-shim (remoteloader) today. till
then both sides were using ssl to talk to each other. i needed to
configure the engine´s driver configuration settings to not use a kmo to
get all up and working again.

details:
--- status as of 08:52 ---
eventvwr.msc:
08:52
source: dirxml remote loader
event id: 1
type: error
driver: <driverlocation\drivername>
thread: subscriber channel
object:
message: connection was broken

tracefile:
DirXML: [06/22/09 08:52:36.26]: ADDriver: object changes complete
DirXML: [06/22/09 08:52:45.54]:
DirXML Log Event -------------------
Driver =
\my-tree\mycompany\ou\driverset_oneofmore\driver_oneof more
Thread = Connection Receiver
Level = warning
Message = SSL protocol-violating EOF found or I/O error:
DirXML: [06/22/09 08:52:45.54]:
DirXML Log Event -------------------
Driver =
\my-tree\mycompany\ou\driverset_oneofmore\driver_oneof more
Thread = Subscriber Channel
Level = error
Message = Connection was broken

--- actions taken ---
restart of remoteloader
restart of driver
down remoteloader, restart driver, restart remoteloader
check config of driver

---- result ---
eventvwr.msc:
10:28
source: dirxml remote loader
event id: 1
type: error
Driver :
Thread : Subscriber Channel
Object :
Message : SSL protocol-violating EOF found or I/O error:

tracefile:
DirXML: [06/22/09 08:52:36.26]: ADDriver: object changes complete
DirXML: [06/22/09 08:52:45.54]:
DirXML Log Event -------------------
Driver =
\my-tree\mycompany\ou\driverset_oneofmore\driver_oneof more
Thread = Connection Receiver
Level = warning
Message = SSL protocol-violating EOF found or I/O error:
DirXML: [06/22/09 08:52:45.54]:
DirXML Log Event -------------------
Driver =
\my-tree\mycompany\ou\driverset_oneofmore\driver_oneof more
Thread = Subscriber Channel
Level = error
Message = Connection was broken

DirXML Log Event -------------------
Driver:
\my-tree\mycompany\ou\driverset_oneofmore\driver_oneof more
Channel: Subscriber
Status: Retry
Message: Code(-9006) The driver returned a "retry" status
indicating that the operation should be retried later. Detail from
driver: No connection to remote loader

--- actions taken ---
remove 'KMO=<kmoobject'>from Remote loader connection parameters in
driver configuration and restart driver

---- result ---
driver can again communicate with remoteloader, though no more via ssl




so the remoteloader-side (see appended config) ssl configured, driver
configuration though has ssl not set (by not configuring a kmo-object) -
anyone has seen this before? what could cause this? who can i get
ssl-communications work again?


thanks in advance, florian


appendix:
remoteloader-config:

-description "AD-METADIR"
-commandport 8000
-connection "port=8090 rootfile='C:\Novell\RemoteLoader\CERT\my-tree
Organizational CA.b64'"
-trace 3
-tracefile "C:\Novell\RemoteLoader\AD-METADIR-Trace.log"
-tracefilemax 20M
-module "C:\Novell\RemoteLoader\ADDriver.dll"

... registry-entries do have values accordingly


--
florianz
------------------------------------------------------------------------
florianz's Profile: http://forums.novell.com/member.php?userid=210
View this thread: http://forums.novell.com/showthread.php?t=377345