I have a Domino driver that is working on a server in my location. I
have the driver and remote loader on the same machine with a Notes
client. The is pointing to a Domino 8 server, SERVER05, and when an add
event is encountered for this location based on the 'l' attribute, I
change the mailserver to SERVER2, for the mail file creation. Like
this:

<xsl:when test="string($l) = 'USA - Location1'">
<xsl:message>### Certifier for Location1 selected ###</xsl:message>
<xsl:attribute
name="cert-id">d:\lotus\notes\data\LOCATION1.ID</xsl:attribute>
<xsl:attribute name="cert-pwd">password</xsl:attribute>
<xsl:attribute
name="notes-policy-name">/Location1/Corporate</xsl:attribute>
<xsl:attribute name="user-pwd">
<xsl:value-of select="$shortname"/>
</xsl:attribute>
<add-attr attr-name="MailServer">
<value>cn=SERVER2/o=Corporate</value>
</add-attr>
</xsl:when>


This works as expected, the ID file goes into the recovery database and
the mail file gets created on SERVER2.

When I add a rule for another location I get an error in the Remote
Loader trace that looks like this:

DirXML: [06/04/09 08:19:26.83]: TRACE: NotesInt: createMailFile -
Unable to open mail file (mail\KOmega.nsf) from template (inotes6g.ntf).
ID = 4063. Message: Database CN=SERVER6/O=Corporate!!inotes6g.ntf has
not been opened yet.

Looking around I came across this:

'10097572: Unable to create mail file mail\NotesUser.nsf'
(http://support.novell.com/docs/Tids/.../10097572.html)

I had the Notes admin verify that the ID that runs the driver has
creation rights, which it does via group memberships.

I'm not sure about the line related to DNS since the Domino servers
should talk to each other based on connection documents in the NAB.

I did find that the first outside server that I tried does have a
machine name that doesn't match the CN of the server in Domino, so I ran
a test on a server that does match and got the same results.

Finally, since the connection works from the hub server to the mail
server here, I don't think I need to rebuild the remote loader or the
driver.

I am at a loss since I don't know much about how AdminP takes and
processes the requests from DirXML, and I was unable to find any kind of
failure on the domino side when these errors show up during creation.

The only other thing I can think to try at this point is to create a
second driver instance that points at the remote server. This way I can
restrict only traffic to that server wihtout having to rely on AdminP
requests from one server to another.

Has anyone else rnu across this problem and been able to fix it?

As an after thought, does the client that I'm using for the remote
loader configuration have to have a connection to the remote server for
this to work, or is it just the server that I'm sending events to that
needs that information?


--
acherro
------------------------------------------------------------------------
acherro's Profile: http://forums.novell.com/member.php?userid=33305
View this thread: http://forums.novell.com/showthread.php?t=375063