Hi everyone,

I got stuck on a strange thing but i guess it's very simple and i'm a
little bit dumb with it.

I want to use the driver's option to migrate data from another
directory (let's call it LDAP) to my eDirectory. (This external
directory is also an eDir that i access via an LDAP driver.)
The only object i use is User, with two attributes.
Here is my mapping table :

EDIR <--> LDAP
User <--> inerOrgPerson
CN <--> cn
destinationIndicator <--> internationaliSDNNumber

But here is my problem: when i start the data migration using the
migrate option to IDVault via iManager, my rules don't work.
The condition is "operation attribute(destinationIndicator) is
available" but it seems that the destinationIndicator is never
available...
I don't understand why because i set the filter correctly,
destinationIndicator can pass through the driver in both directions. And
the mapping should normally change the internationaliSDNNumber to
destinationIndicator before my rules are processed...

Well maybe i don't init the migration correctly:
I pick the User class, and next i can choose to pick either
destinationIndicator or internationaliSDNNumber, or both maybe, i don't
know which one i have to choose, i try both of it but it didn't work
And when i pick some attributes i have to set a value, i tried with *
for the wanted attributes but maybe it's not the proper syntax...
I tried a lot of options to init the migration but each time, my rules
don't get the destinationIndicator attribute so i don't know what i do
wrong.

Well hoping someone could help me, this is kind of an emergency :s

Thanks for support,
SJ.


--
sjahan
------------------------------------------------------------------------
sjahan's Profile: http://forums.novell.com/member.php?userid=16002
View this thread: http://forums.novell.com/showthread.php?t=350627