When issuing a search request using the SOAP-DSML configuration, the driver
is sending two XML documents.
The "default' stylesheets have not been modified. (As far as we know).
Identity Manager 3.0.10.6614
Driver ID: SOAP Driver version: 1.0.3

Tracing the oputput shows:

<nds dtdversion="3.0" ndsversion="8.x">
<source>
<product version="3.0.10.20060630 ">DirXML</product>
<contact>Novell, Inc.</contact>
</source>
<output>
<instance class-name="inetOrgPerson" event-id="searchRequest"
qualified-src-dn="O=willeke\OU=people\CN=WilleJ01"
src-dn="\FNIDV-TEST\willeke\people\WilleJ01" src-entry-id="33907">
<association
state="associated">cn=WilleJ01,ou=people,o=willeke </association>
<operation-data startedAs="query">
<return-to-me command="query" derefAliases="derefInSearching"
dn="cn=WilleJ01,ou=people,o=willeke" requestID="1" scope="baseObject"
sizeLimit="10" timeLimit="10000" typesOnly="false"/>
</operation-data>
<attr attr-name="cn">
<value naming="true" timestamp="1204567718#23"
type="string">WilleJ01</value>
</attr>
<attr attr-name="sn">
<value timestamp="1204567718#3" type="string">Willeke</value>
</attr>
<attr attr-name="givenname">
<value timestamp="1204567718#4" type="string">James</value>
</attr>
</instance>
<soap-env:Envelope
xmlns:soap-env="http://schemas.xmlsoap.org/soap/envelope/">
<soap-env:Body>
<batchResponse xmlns="urnasis:names:tcSML:2:0:core"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<searchResponse>
<searchResultEntry dn="CN=WilleJ01,OU=people,O=willeke">
<attr name="cn">
<value>WilleJ01</value>
</attr>
<attr name="sn">
<value>Willeke</value>
</attr>
<attr name="givenname">
<value>James</value>
</attr>
</searchResultEntry>
<searchResultDone requestID="searchRequest">
<resultCode code="0" descr="success"/>
</searchResultDone>
</searchResponse>
</batchResponse>
</soap-env:Body>
</soap-env:Envelope>
</output>
</nds>
15:17:15 72580BB0 Drvrs: PostHandler.handle() Response sent.

It appears the "<instance " document is not being removed from the output
being sent.
So the application recives only the all that is above and grabs the
"Instance" document ignoring the soap envelope.

Only happens on Search, add, modify and delete seem to be fine.

Anyone have some ideas on where to fix this?

Thanks
-jim