All,



I'm having a hard time trying to create a home directory for a new user
created in AD 2003. My condition statement is working except when on the AD
side. I was under the impression this should create the home directory on
the server I specify. Here is my code for the home drive and home directory
creation. I've tried using &username& as well. Any thoughts!



</rule>

<rule>

<description>Default home directory</description>

<conditions>

<and>

<if-class-name
op="equal">User</if-class-name>

</and>

</conditions>

<actions>

<do-set-dest-attr-value
name="homeDrive">

<arg-value type="string">

<token-text
xml:space="preserve">Y:</token-text>

</arg-value>

</do-set-dest-attr-value>

<do-set-dest-attr-value
name="homeDirectory">

<arg-value type="string">

<token-text
xml:space="preserve">\\server-name\users\</token-text>

<token-src-name/>

</arg-value>

</do-set-dest-attr-value>

</actions>

</rule>





Trace from the RL AD side.



DirXML: [12/20/07 08:49:23.27]: ADDriver: ldap_modify user
CN=RLCoulson,ou=Departmenat,ou=People,dc=company,d c=lab

LDAPMod operations:

delete attribute homeDrive

add attribute homeDrive

>> Y:


delete attribute homeDirectory

add attribute homeDirectory

>> \\server-name\users\RLCoulson


replace attribute userAccountControl

>> 544


DirXML: [12/20/07 08:49:23.27]: Loader: subscriptionShim->execute()
returned:

DirXML: [12/20/07 08:49:23.27]: Loader: XML Document:

DirXML: [12/20/07 08:49:23.27]: <nds ndsversion="8.7" dtdversion="1.1">

<source>

<product version="3.5.1" asn1id=""
build="20070823_095000" instance="\MDAIDV\system\SERVICES\MDA
DriverSet\TEST-AD-Migration">AD</product>

<contact>Novell, Inc.</contact>