When you want to import users from the Application into the IDV, you
pick an object class, and you can pick an attribute to query on.

Sometimes you can use a wildcard (usually *) in the query so that you
could say Users, Surname=A* to get a small subset of users.

I know this has worked as I have used it in the past. I recall a 'bug'
in the Notes shim that * was a specail character in Notes and so that
did not work, so they had to do something to work around it.

In the case of the JDBC driver, pointing at a Oracle 9.x DB what is the
wildcard character? I tried % which is Oracle's wildcard character. I
tried * and neither worked.

A SQL SELECT * from SCHEMA.TABLE where LASTNAME like 'A%' works from a
SQL command.

Clearly the JDBC driver does not send a query as a LIKE test... I did
not look on the shim trace, but I would bet it sent it as a WHERE
LASTNAME='A%' style query, which does not work from SQL for me here, it
returns an empty set. Whereas the LIKE 'A%' returns 500 users.

Any hints?

IDM 3.5, latest JDBC driver, latest Oracle JDBC Jar (ojdbc14.jar) on
SLES 10 SP1 with eDIr 8.8 SP1 with the FP2 engine patch.