We have a NIS driver on IDM2 that is using files that is behaving
strangely. I am trying to add a default gidNumber on user create,
exactly how i'm doing it for loginShell and some other attributes.

The code is as follows -

</rule>
<description>Add gidNumber</description>
<conditions>
<and>
<if-class-name op="equal">User</if-class-name>
</and>
</conditions>
<actions>
<do-set-dest-attr-value name="gidNumber">
<arg-value>
<token-text>102</token-text>
</arg-value>
</do-set-dest-attr-value>
</actions>
</rule>

This processes fine until the end of the operation, when an error occurs
in the trace -

<nds dtdversion="2.0" ndsversion="8.x">
<output>
<status event-id="#20070724014235#1#68" level="error"
type="driver-general">Invalid Group:java.lang.NoSuchFieldException:
Invalid gidNumber for User</status>
<status event-id="#20070724014235#1#68" level="error"
type="driver-general">ERROR</status>
</output>
</nds>

The remote loader trace shows the same error.

If I run the dxnis command it works fine!

dxnis -n files -m -r -p addUser:testnis6:::102:test
nis6:/home/testnis6:/bin/bash::::::::

I'm guessing its some kind of issue with the driver as it doesnt think
102 is a valid group, but it is.

I'm probably going to upgrade to IDM35 and the new bidirectional Linux
driver, but this one has me stumped as it should be working.