We currently use IDM starter pack (IDM2.0.1) to synchronize passwords
between eDirectory and AD.

Are there any issues with upgrading the Server 2k3 running the AD remote
loader to SP2?

Thanks,
Dave