Hi all

Problem:

I have a AS400 Connector, Through which I tried to create unique
CN(Profiles) in the AS400 System, using the following XSLT in the Creation
policy.

http://support.novell.com/techcenter...a20011205.html

This worked fine for me in Notes and SunOne LDAP Systems, but here in
this AS400 Connector if the generated CN already exists in the System the
fallback to create the next iteration CN is not happening. I guess that
destination query is not working.

Here I have mapped CN with USRPRF, please let me know how to fix this
issue.

I create two Users

User 1:

First Name : Peterson
Last Name : Doe

Expected CN Creation with respective to XSLT is DOEP – Success.

User 2:
First Name : Peterson1
Last Name : Doe

Expected CN Creation with respective to XSLT is DOEPE – Failure,
Once again DOEP is getting created.

from the NDS error log I picked the following piece, which shows that the
query is not getting the expected output from the AS400 Shim

<nds dtdversion="1.0" ndsversion="8.5"
xmlns:query="http://www.novell.com/nxsl/java/com.novell.nds.dirxml.driver.XdsQueryProcessor">

<input>

<query event-id="0">

<search-class class-name="UserProfile"/>

<search-attr attr-name="USRPRF">

<value>DOEP</value>

</search-attr>

<read-attr/>

</query>

</input>

</nds>

[05/08/07 08:56:36.603]: AS400 ST: Remote Interface Driver: Document
sent.

[05/08/07 08:56:37.024]: AS400 : Remote Interface Driver: Received.

[05/08/07 08:56:37.025]: AS400 :

<nds dtdversion="1.1" ndsversion="8.6">

<source>

<product build="20070223_1107" version="2.0"/>

<contact/>

</source>

<output/>

</nds>

From the AS400 Shim, I got the error

Query called

Query Helper Starting

ERROR: "could not retrieve scope"

I am using midrange 2.0 with patch 2

please let me know how to fix this issue..

Thanks in Advance

Sri