i guess i probably knew this in the back of my head somewhere but
overlooked.

if you are upgrading to idm35 and your driverset has more than one server
in it, you will not be able to use the new plugin(except for start/stop)
until all servers in the driverset are upgraded.

kind of caught me off guard today.