OES2SP3 with the latest patches gets 8.8.7 (patch4), so there's no need to stay with 8.8.5. And if you have OES2SP2 or earlier you need to get to SP3 ASAP.