Hi,

After months of working correctly our peoplesoft driver is failing. We
have DirXML 2 running on suse9 connecting to peoplesoft via the 5.1
driver. In the logs we are seeing
a "<description>com.novell.nds.dirxml.driver.psoftsh im.CIException:
PropertyInfoCollection Processing failed for schema:
DIRXML_SCHEMA01</description>" error quite often. Apparently there have
been no changes on the PSoft side apart from a reboot and after that the
problems have been occuring. We upgraded to the 5.1 driver a few weeks
ago but the problem don't seem to have start until the reboot on the
Psoft side. Here is a further example of the errors from the logs:-

<nds dtdversion="2.0">
<output>
<status level="error" type="app-general">
<description>com.novell.nds.dirxml.driver.psoftshi m.CIException:
PropertyInfoCollection Processing failed for schema:
DIRXML_SCHEMA01</description>
</status>
</output>
</nds>

DirXML Log Event -------------------
Driver: \Tree\GROUP\Services\DriverSet\Driver set
Channel: Publisher
Status: Error
Message:
<description>com.novell.nds.dirxml.driver.psoftshi m.CIException:
PropertyInfoCollection Processing failed for schema:
DIRXML_SCHEMA01</description>
[04/03/07 11:45:06.149]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: retrieveTransactionRecord(DIRXML_TRANS01)
[04/03/07 11:45:06.150]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: Connection not valid.
[04/03/07 11:45:06.150]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: disconnect
[04/03/07 11:45:06.150]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: connect
[04/03/07 11:45:06.353]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: initTransactionComponent
[04/03/07 11:45:06.353]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: getMetaData
[04/03/07 11:45:06.353]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: retrieveMetaData
[04/03/07 11:45:06.670]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: getComponentProperties
[04/03/07 11:45:06.670]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: processSchemaCollection
[04/03/07 11:45:09.228]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: CurrDate: 2007-04-03-11.45.15.000000
[04/03/07 11:45:09.228]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: ActionDate: 2007-04-01-00.00.00.000000
[04/03/07 11:45:09.561]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: getTransDataRecord
[04/03/07 11:45:09.561]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: getDataRecord (Transaction)
[04/03/07 11:45:09.561]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: readDataRecord
[04/03/07 11:45:09.724]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: getMetaData
[04/03/07 11:45:09.724]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: retrieveMetaData
[04/03/07 11:45:10.202]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: getComponentProperties
[04/03/07 11:45:10.203]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: processSchemaCollection
[04/03/07 11:45:10.581]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: disconnect
[04/03/07 11:45:10.581]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: RDR: Unable to obtain schema for 'DIRXML_SCHEMA01'
[04/03/07 11:45:10.581]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: disconnect
[04/03/07 11:45:10.582]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: disconnect
[04/03/07 11:45:10.582]: Our_driver_set_namePT: PeopleSoft CI
Driver\CIConnector: disconnect
[04/03/07 11:45:10.582]: Our_driver_set_namePT: Receiving DOM document
from application.
[04/03/07 11:45:10.582]: Our_driver_set_namePT:


Any idea would be greatly appreciated!

Thanks,
Matt