I have set up a rule that vetos a user delete event and sends an email to
the modifier saying "You can't delete a user, etc.". The rule works fine
and dandy, but sometimes I receive two or three of the same emails at the
same time.......and other times I receive just the one??? The dstrace
doesn't show any kind of error.....and the rule works fine. I am not sure
why sometimes I get duplicates???? Any ideas?

The rule below is set up in the eDir driver in the Event Transformation
Policy. Any ideas as to why I receive more than one email notification
(with the same timestamp and message)?

Thanks, Jordan

<?xml version="1.0" encoding="UTF-8"?><policy>
<rule>
<description>Veto new user of employee type E if coming
from other tree</description>
<conditions>
<and>
<if-class-name op="equal">User</if-
class-name>
<if-operation op="equal">add</if-
operation>
<if-src-attr name="employeeType"
op="equal">E</if-src-attr>
</and>
</conditions>
<actions>
<do-send-email server="IRelay4u">
<arg-string name="to">
<token-parse-dn dest-dn-
format="slash" length="1" src-dn-format="ldap" start="-1">
<token-src-attr
name="creatorsName"/>
</token-parse-dn>
<token-text
xml:space="preserve">@dot.state.tx.us</token-text>
</arg-string>
<arg-string name="subject">
<token-text
xml:space="preserve">Please create user through front-end</token-text>
</arg-string>
<arg-string name="message">
<token-text
xml:space="preserve">The user you recently created ( </token-text>
<token-op-attr
name="Surname"/>
<token-text
xml:space="preserve">, </token-text>
<token-op-attr name="Given
Name"/>
<token-text
xml:space="preserve">) with a source DN of </token-text>
<token-src-dn/>
<token-text
xml:space="preserve"> was not created using the web front-end. This user
account has been DELETED. Please re-enter the user account through the
front-end. </token-text>
</arg-string>
</do-send-email>
<do-delete-src-object/>
<do-veto/>
</actions>
</rule>
</policy>