Hi Guys,

Having a look for another issue on a Sentinel 7 server and I have
noticed the following errors in the following logs, for simplicity I
have removed dates and times and replaced the qtp number with
XXXXXXXXX-XXXXXXX:

Server_wrapper.log


Code:
--------------------
| INFO | jvm 1 | SEVERE|ActiveMQ Task|org.apache.activemq.broker.TransportConnector $1.onAcceptError
| INFO | jvm 1 | Could not accept connection : javax.net.ssl.SSLHandshakeException: Received fatal alert: certificate_unknown
--------------------


server0.0.log


Code:
--------------------
|SEVERE|ActiveMQ Task|org.apache.activemq.broker.TransportConnector $1.onAcceptError
Could not accept connection : javax.net.ssl.SSLHandshakeException: Received fatal alert: certificate_unknown
|INFO|qtpXXXXXXXXX-XXXXXXX|com.novell.sentinel.restservices.connectio n.ConnectionCheckResource.connectionTest
Connection tested successfully

|SEVERE|ActiveMQ Task|org.apache.activemq.broker.TransportConnector $1.onAcceptError
Could not accept connection : javax.net.ssl.SSLHandshakeException: Received fatal alert: certificate_unknown
|SEVERE|ActiveMQ Task|org.apache.activemq.broker.TransportConnector $1.onAcceptError
Could not accept connection : javax.net.ssl.SSLHandshakeException: Received fatal alert: certificate_unknown
|INFO|qtpXXXXXXXXX-XXXXXXX|com.novell.sentinel.restservices.connectio n.ConnectionCheckResource.connectionTest
Connection tested successfully
--------------------


So it seems like there is a certificate error however its not too clear
where. I can see its coming from the activemq.broker, but surely this
would affect comms to and from the collector managers in that case to
Sentinel? I can see I am receiving events through from the collector
managers, however still seeing these errors in the logs. To be honest
every day use of the product I cant actually find any functionality that
this is affecting, the only other issue on this box relates to reporting
and as far as I was aware activemq would not be involved with the
reporting side.

Is there a way to debug this further to work out which certificate the
error is relating to? As far as I know no certs have been changed on the
box since installation time, however I cannot guarantee this as I am not
the sole user of the server What is likely to cause this error?

Thanks in advance


--
alanforrest
------------------------------------------------------------------------
alanforrest's Profile: http://forums.novell.com/member.php?userid=90508
View this thread: http://forums.novell.com/showthread.php?t=458878