This is a 'fresh' install of the User Application (with Provisioning) on
SLES10 SP2/OES 2. The User Application driver (3.5.1) was installed
using the config wizard in Designer (config version 1, no Roles Based
Provisioning). JBoss and mySQL were installed using the supplied
installer. The User App was then successfully installed using its own
installer. I don't have any prior experience with the User App, so if
I've done something fundamentally wrong here, please let me know. I
haven't done any configuration of/created any workflows in the User App
driver in the identity vault, other than the default
configuration/workflows created by the config wizard.

The JBoss server starts up and I can successfully log in as the admin
user. When I click on the Request & Approvals link at the top of the
page I receive the following error:
========================================
HTTP Status 500 - No action instance for path /getAFTaskList could be
created
type Status report
message No action instance for path /getAFTaskList could be created
description The server encountered an internal error (No action
instance for path /getAFTaskList could be created) that prevented it
from fulfilling this request.
JBossWeb/2.0.0.GA
========================================

The server error log shows the following error:
========================================
12:19:12,510 ERROR [GetAFTaskList] Failed to initialize workflow
related components!
java.lang.NoClassDefFoundError
at
com.novell.srvprv.apwa.actions.APWABaseAction.<ini t>(APWABaseAction.java:124)
at
com.novell.srvprv.apwa.actions.APWABaseDispatchAct ion.<init>(APWABaseDispatchAction.java:52)
at
com.novell.srvprv.apwa.actions.APWASelectorActionB ase.<init>(APWASelectorActionBase.java:72)
at
com.novell.srvprv.apwa.actions.APWAFilteredListAct ionBase.<init>(APWAFilteredListActionBase.java:65)
at
com.novell.srvprv.apwa.actions.GetAFTaskList.<init >(GetAFTaskList.java:75)
at
sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
at
sun.reflect.NativeConstructorAccessorImpl.newInsta nce(Unknown Source)
at
sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(Unknown
Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
========================================
A more complete error log is attached.

I suspect that the first three lines are the important ones. Am I
missing a class somewhere? Is there some configuration that I haven't
completed yet? Any other hints, tips or suggestions?

I've searched the support DB, the forums and Google and as yet haven't
come up with anything useful. If you require any further information to
help debug this, please let me know.

Thanks in advance.


+----------------------------------------------------------------------+
|Filename: UserApp_GetAFTaskListError.txt |
|Download: http://forums.novell.com/attachment....achmentid=2195 |
+----------------------------------------------------------------------+

--
ChrisReeves
------------------------------------------------------------------------
ChrisReeves's Profile: http://forums.novell.com/member.php?userid=34172
View this thread: http://forums.novell.com/showthread.php?t=357289