I'm trying to use the walkthrough here:
'Community: RunJBossAsAServiceOnWindows'
(http://www.jboss.org/community/docs/DOC-11932)

The User App is starting correctly when I use the batch file
start-jboss.bat. This is the wrapper.conf I am using:

=================================================
wrapper.java.command=D:/Novell/idm/jre/bin/java

wrapper.java.mainclass=org.tanukisoftware.wrapper. WrapperSimpleApp

wrapper.java.classpath.1=%JBOSS_HOME%/lib/wrapper.jar
wrapper.java.classpath.2=%JAVA_HOME%/bin/java/lib/tools.jar
wrapper.java.classpath.3=./run.jar
wrapper.java.classpath.4=%JBOSS_HOME%/lib/endorsed/xalan.jar


wrapper.java.library.path.1=%JBOSS_HOME%/lib

# these are the JAVA_OPTS
wrapper.java.additional.1=-server
# enviroment variables - define the ones that match your desired
environment
# wrapper.java.additional.2=-Denviromnment.variable=value
# memory parameters - define the ones that match your desired
environment
wrapper.java.additional.2=-Xms256m
wrapper.java.additional.3=-Xmx256m
wrapper.java.additional.4=-XX:MaxPermSize=128m
# If you need serialization suppport
# wrapper.java.additional.5=-Dsession.serialization.jboss=true

wrapper.app.parameter.1=org.jboss.Main
# Parameters to be passed to the application (Jboss)
# Define server name (configuration) - If you need a config that is
different than the "default" or need to run multiple configs
wrapper.app.parameter.2=-c IDMProv -b 0.0.0.0
# Define listening IP - If you have more than one IP or want to
indicate to listen on a specific IP
#wrapper.app.parameter.3=NOTHING HERE
# wrapper log location
wrapper.logfile=%JBOSS_HOME%/server/IDMProv/log/wrapper.log

# You must not change below parameters without first uninstall the
service
# service name
wrapper.ntservice.name=JbossIDMProv
# service display name
wrapper.ntservice.displayname=JBoss Server IDMProv
=================================================

I will attach the log file from the wrapper process. Here is what I
think is the pertinent part:

INFO | jvm 1 | 2009/01/15 14:53:49 | 14:53:49,551 INFO
[SessionFactoryImpl] building session factory
INFO | jvm 1 | 2009/01/15 14:53:52 | 14:53:52,269 INFO
[SessionFactoryObjectFactory] Not binding factory to JNDI, no JNDI name
configured
INFO | jvm 1 | 2009/01/15 14:53:53 | 14:53:53,332 FATAL
[EboDirectoryFactory] An unexpected exception occurred in the directory
layer.
INFO | jvm 1 | 2009/01/15 14:53:53 |
com.sssw.fw.exception.EboUnrecoverableSystemExcept ion: An unexpected
exception occurred in the directory layer.
INFO | jvm 1 | 2009/01/15 14:53:53 | at
com.sssw.fw.directory.realm.impl.jndildap.EboLdapD irectoryConnection.createBaseContext(EboLdapDirect oryConnection.java:308)
INFO | jvm 1 | 2009/01/15 14:53:53 | at
com.sssw.fw.directory.realm.impl.jndildap.EboLdapD irectoryConnection.authenticate(EboLdapDirectoryCo nnection.java:166)
INFO | jvm 1 | 2009/01/15 14:53:53 | at
com.sssw.fw.directory.realm.impl.jndildap.EboLdapD irectoryConnectionManager.createConnectionArray(Eb oLdapDirectoryConnectionManager.java:327)
INFO | jvm 1 | 2009/01/15 14:53:53 | at
com.sssw.fw.directory.realm.impl.jndildap.EboLdapD irectoryConnectionManager.<init>(EboLdapDirectoryC onnectionManager.java:103)
INFO | jvm 1 | 2009/01/15 14:53:53 | at
com.sssw.fw.directory.realm.impl.jndildap.EboJndiL dapDirectoryFactory.createConnectionMgrInstance(Eb oJndiLdapDirectoryFactory.java:114)

It looks like the process is not authenticating correctly against
eDirectory when I try to use the wrapper. I'm not sure where the
authentication stuff is being stored/retrieved during the
start-jboss.bat process so I'm not sure what to do next.

Thanks for any help.


+----------------------------------------------------------------------+
|Filename: wrapper.log |
|Download: http://forums.novell.com/attachment....achmentid=2179 |
+----------------------------------------------------------------------+

--
nate_spears
------------------------------------------------------------------------
nate_spears's Profile: http://forums.novell.com/member.php?userid=7564
View this thread: http://forums.novell.com/showthread.php?t=356963