Hi all,

I'm trying to start a workflow from a java class.
I keep having the same error :


Code:
--------------------
com.novell.soa.af.impl.soap.AdminException={_Reaso n= Process requestId [753467bdcf4a45fc84cbbe6942548022], Id [cn=Sous-demande,cn=RequestDefs,cn=AppConfig,cn=UserApplica tion,cn=myDriverSet,ou=service,o=TEST] : error evaluating data items.}
at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at com.novell.soa.af.impl.soap.AdminExceptionMarshale r.deserialize(AdminExceptionMarshaler.java:30)
at com.novell.soa.ws.impl.soap.LiteralEncodingStyle.r eadObject(LiteralEncodingStyle.java:260)
at com.novell.soa.ws.impl.soap.LiteralEncodingStyle.r eadObject(LiteralEncodingStyle.java:239)
at com.novell.soa.ws.impl.soap.LiteralEncodingStyle.r eadObject(LiteralEncodingStyle.java:217)
at com.novell.soa.ws.impl.xml.InputStreamImpl.readObj ect(InputStreamImpl.java:82)
at com.novell.soa.af.impl.soap.ProvisioningBinding_St ub.start(ProvisioningBinding_Stub.java:2724)
at com.TEST.ADM.Batchs.Connections.WSClient.getProvRe quest(WSClient.java:93)
at com.TEST.ADM.Batchs.Batch1.main(Batch1.java:115)
--------------------


My Java class is joined to this post. I found an old thread on this
forum concerning the mapping, but it seems to be correct (all fields are
present).

Any idea ?


--
mbaptiste
------------------------------------------------------------------------
mbaptiste's Profile: http://forums.novell.com/member.php?userid=30784
View this thread: http://forums.novell.com/showthread.php?t=349124