Ok, so Designer 2.1.1, UA 3.51 (Patch L), on SLES 10 SP1.

Have a PRD I am working with, in the request form I define a driverdn
field, set it to DN syntax, DNLookup.

Initially when I added it at first, hit the browse button on the form,
and the pop up box came up empty and without any widgets to click or the
like.

Ok, go into the DAL, make the object Class Include in search, specify a
base container, only look one container scoping. Set to perform
automatic query.

Happens to be DirXML-Driver is my object class of choice for a reason
apparent to us here.

Looking at LDAP trace, I see it look, and find the values I want:

11:30:54 B231CBA0 LDAP: DoSearch on connection 0x8216cd8
11:30:54 B231CBA0 LDAP: Search request:
base: "CN=IDVAULT,OU=SERVICES,O=LAB"
scope:1 dereference:0 sizelimit:0 timelimit:0 attrsonly:0
filter:
"(&(objectClass=DirXML-Driver)(objectClass=acmeDirXMLDriverAux))"
attribute: "srvprvHideUser"
attribute: "srvprvHideAttributes"
attribute: "modifyTimeStamp"
attribute: "objectClass"
11:30:54 B231CBA0 LDAP: Sending search result entry "cn=eDirectory
Driver,cn=IDVAULT,ou=SERVICES,o=LAB" to connection 0x8216cd8
11:30:54 B231CBA0 LDAP: Sending search result entry
"cn=SolarisV,cn=IDVAULT,ou=SERVICES,o=LAB" to connection 0x8216cd8
11:30:54 B231CBA0 LDAP: Sending search result entry
"cn=APP,cn=IDVAULT,ou=SERVICES,o=LAB" to connection 0x8216cd8
11:30:54 B231CBA0 LDAP: Sending search result entry "cn=Active
Directory,cn=IDVAULT,ou=SERVICES,o=LAB" to connection 0x8216cd8
11:30:54 B231CBA0 LDAP: Sending search result entry "cn=IDVault - VPN
Driver,cn=IDVAULT,ou=SERVICES,o=LAB" to connection 0x8216cd8
11:30:54 B231CBA0 LDAP: Sending search result entry "cn=LOG Debug-DO NOT
RUN IN PRODUCTION,cn=IDVAULT,ou=SERVICES,o=LAB" to connection 0x8216cd8
11:30:54 B231CBA0 LDAP: Sending search result entry
"cn=APP-CSV,cn=IDVAULT,ou=SERVICES,o=LAB" to connection 0x8216cd8
11:30:54 B231CBA0 LDAP: Sending operation result 0:"":"" to connection
0x8216cd8

It even added my Aux class and only found objects populated with it.
Excellent all around.

Yet the pop up window where it should display the list, and allow me to
choose the driverDN I care about... But it is empty with nothing to do
but close.

What did I miss?