I'm working on a workflow that will submit tickets to our internal ticketing
application via SOAP. I have tested the API via soapUI and it works
perfectly, however when adding it to my workflow as an Integration Activity
I get the following error:

Workflow Error: Process requestId [84b88fa207cf4ea9abe1b7a0fb5c59e3], Id
[cn=UserTerm,cn=RequestDefs,cn=AppConfig,cn=UApp36, cn=Test SIM Driver
Set,o=services], Integration activity [Activity]: faulted [<?xml
version="1.0" encoding="UTF-8"?> <m:FaultInfo
xmlns:m="http://novell/extendComposer/SystemFault"> <mateTime>Fri Jun 06
11:42:31 CDT 2008</mateTime> <m:ComponentName>VAULT_UApp36_Terminate
User_Activity</m:ComponentName> <m:MainCode>-1</m:MainCode>
<m:SubCode>1</m:SubCode> <m:Message>com.sssw.b2b.rt.GNVException:
rt007005:Error encountered executing WSDL Action:; ---&gt; nested
java.lang.RuntimeException: javax.net.ssl.SSLHandshakeException:
sun.security.validator.ValidatorException: PKIX path building failed:
sun.security.provider.certpath.SunCertPathBuilderE xception: unable to find
valid certification path to requested target</m:Message> </m:FaultInfo> ].

I am assuming this is an SSL related issue since this site does use https
for the submission, however I have tried to add a self signed cert and
private key w/ password to the config and it still gives the same error.
Just as a test, I did a similar workflow to a different system and submitted
over http and it completed without error. What cert am I supposed to import
and what are the steps for the import??

Any help is appreciated!!

Joey