Hello,

In my workflow I need to define a new entity called "pole" which allows
the user to select a specific OU from a given OU.

In Designer, I have created a new entity called "pole" which class is
"Organizational Unit" with the attributes OU and Description.
I have tried to define it the same way User entity is defined.

The control type of the field linked to this entity "pole" in my
request_form is "DNLookup".
I have set up the entity key for DN expression property to "Pole" and
object selector type is container.

I have deployed all DAL and PRD.

Problem is that when user logs on User Application and tries to create
a Request Resource, as he selects the control type pole, the following
error appears :


Pôle: Please check the values that you specified for the entity or
root dn properties for this field:
Service returned error. Return code=500, Message=Error encountered
while executing the service lookupcontainer: {1}.,
Throwable= Unable to find abstract layer object definition for the
following definition key: Pole: {1}.


If I look on Entities in Designer, I remark the following tool tips for
the entities
Group : CN: group, ClassName:srvprvEntity Description:Group Definition
Pole : CN: Pole, ClassName:srvprvEntity
User : CN: user, ClassName:srvprvEntity Description:User Definition
User : CN: user-lookup, ClassName:srvprvEntity Description:User Lookup



I think something is missing in my entity pole (the definition ?) but I
don't see how to find it.
I have tried to export to file (Entities.xml) the entities to see a
difference between the entities definitons but I don't see anything
special.

Perhaps have you an idea about the way to resolve this problem ?
Thank you for your help,

Christine


--
coves
------------------------------------------------------------------------
coves's Profile: http://forums.novell.com/member.php?userid=4568
View this thread: http://forums.novell.com/showthread.php?t=329339