When I last reinstalled UserApp (3.5.1), I forgot to configure it to use
an LDAP proxy user. So I'm trying to do that now via the configupdate.sh
script. This is on SLES9. I run the script, uncheck the "Use Public
Anonymous Account" option, specify my proxy user and password, and click
on "ok".

The GUI window closes, and I get:

idm@linuxvm3:/home/idmua351/ua> ./configupdate.sh
Exception in thread "main" java.util.zip.ZipException: invalid entry
compressed size (expected 18971 but got 19015 bytes)
at java.util.zip.ZipOutputStream.closeEntry(Unknown Source)
at java.util.zip.ZipOutputStream.putNextEntry(Unknown Source)
at
com.novell.internal.installer.idm.ldap.LdapConfig. updateZip(LdapConfig.java:1171)
at
com.novell.internal.installer.idm.ldap.LdapConfig. commit(LdapConfig.java:747)
at
com.novell.internal.installer.idm.ldap.LdapConfig. main(LdapConfig.java:182)
idm@linuxvm3:/home/idmua351/ua>

If I run configupdate.sh again, it looks like it saved the
user/password, but the Use Public Anonymous Account box is still
checked.

Hunting around with find and unzip, it looks like this is probably what
it's complaining about:

Archive: IDM.war
Length Method Size Ratio Date Time CRC-32 Name
-------- ------ ------- ----- ---- ---- ------ ----
19244 Defl:N 19015 1% 10-28-05 16:01 9f1d48f6
resource/themes/IDMStandard/images/thumbnail.gif

Only IDM.war seems to have a file that is 19015 bytes compressed in it,
at least of all of the *.war, *.jar, *.rar, and *.sar files in
/home/idmua351.

So now what? Is there a way to "fix" whatever problem this is? I'd
really rather not have to reinstall UA again right now.



---------------------------------------------------------------------------
David Gersic dgersic_@_niu.edu
Novell Support Forums Volunteer SysOp http://forums.novell.com

Please post questions in the newsgroups. No support provided via email.