The instructions state I have to install Java first. They say to
install the Java Developer kit, but then they say I should use:

jre_1.5.0_10

Questions:

1) the JRE does not include the JDK. That's in a diff. download

2) Where do I get that jre anymore?

3) Can I use 1.6 ?