just had a small problem with password-synchronization which i wanted,
after having an online search which not entirely cleared up what was
going on, to share, respectively consolidate related threads and provide
a (simple) 'solution'.

management summary:
restart the driver-shim (the thing communicating with the
remoteloader).

situation:
edir 8.8.5 / idm 3.6.1 (ad-rloader version is of 3.5.1)
password-synchronisation works for most of the users, but some changes
seem to not to get published to edirectory.
the remoteloader trace shows entries like these:
DirXML: [12/21/10 13:44:53.18]: ADDriver: [PWD] - GetDCKey() domain
controller server05.domain is not in list
DirXML: [12/21/10 13:44:53.18]: ADDriver: [PWD] - list entry[0]=
server01.domain
DirXML: [12/21/10 13:44:53.18]: ADDriver: [PWD] - list entry[1]=
server02.domain
DirXML: [12/21/10 13:44:53.18]: ADDriver: [PWD] - list entry[2]=
server03
DirXML: [12/21/10 13:44:53.18]: ADDriver: [PWD] - list entry[3]=
server03.domain
DirXML: [12/21/10 13:44:54.87]: ADDriver: [PWD] - GetDCKey() domain
controller server04.domain is not in list
DirXML: [12/21/10 13:44:54.87]: ADDriver: [PWD] - list entry[0]=
server01.domain
DirXML: [12/21/10 13:44:54.87]: ADDriver: [PWD] - list entry[1]=
server02.domain
DirXML: [12/21/10 13:44:54.87]: ADDriver: [PWD] - list entry[2]=
server03
DirXML: [12/21/10 13:44:54.87]: ADDriver: [PWD] - list entry[3]=
server03.domain
DirXML: [12/21/10 13:45:05.21]: Loader: Received 'subscriber execute'
document

serverīs logged as "not in the list" are correctly configured
pwfilter-wise (driver-machine = 0 & pointing to the remoteloader-server
correctly). there seems to be have a problem long gone, with the
authentication-context (see: tid) which could cause the problem. as
hinted in several threads as well this might be due to some sort of
misconfiguration of the server objects in Active Directory - checked
that, on first crude check all seems to be fine.

then i restarted the driver-shim and the passwords went through,
problem solved. no idea what was happening there or how to avoid it,
would be interesting though.

-------
(more or less) related threads:
http://forums.novell.com/novell-prod...-not-list.html
http://forums.novell.com/novell-prod...-not-list.html
http://forums.novell.com/novell-prod...-getdckey.html
http://forums.novell.com/novell-prod...word-sync.html
http://forums.novell.com/novell-prod...d-working.html

TID: Cannot connect to remote loader
'10099426: Cannot connect to remote loader'
(http://support.novell.com/docs/Tids/.../10099426.html)


--
florianz
------------------------------------------------------------------------
florianz's Profile: http://forums.novell.com/member.php?userid=210
View this thread: http://forums.novell.com/showthread.php?t=428608