Hello,

I'm currently working in a Loopback.

When I modify two attributes in the filter (stare and department)
through iManager, the driver detects two different events:

<input>
<modify cached-time="20100827121952.202Z" class-name="User"
event-id="linux#20100827121952#1#1" qualified-src-dn="xxx" src-dn="xxx"
src-entry-id="34643" timestamp="1282911592#2">
<modify-attr attr-name="Department">
<remove-value>
<value timestamp="1282911227#2" type="string">5</value>
</remove-value>
<add-value>
<value timestamp="1282911592#2" type="string">6</value>
</add-value>
</modify-attr>
</modify>
</input>

and then ....

<input>
<modify cached-time="20100827121952.361Z" class-name="User"
event-id="linux#20100827121952#1#2" qualified-src-dn="xxx" src-dn="xxx"
src-entry-id="34643" timestamp="1282911592#8">
<modify-attr attr-name="State">
<remove-value>
<value timestamp="1282911209#2" type="string">01</value>
</remove-value>
<add-value>
<value timestamp="1282911592#8" type="string">28</value>
</add-value>
</modify-attr>
</modify>
</input>

but if I query the value of the second modified attribute with
"Attribute(State)" in a rule on the first event the result is 28 (the
new value, that has not yet been processed).

Is this the expected behaviour of the driver?

Many thanks,

Josep.


--
jlmasmit
------------------------------------------------------------------------
jlmasmit's Profile: http://forums.novell.com/member.php?userid=20336
View this thread: http://forums.novell.com/showthread.php?t=419447