Hi,

I am trying to do an LDAP provisioning. The Sun one LDAP directory is
on a remote server. So, I installed a remote loader and configured it
accordingly. Then I installed the LDAP driver in my imanager and
completed the configurations. I have given the correct passwords for
driver object and remote loader.

But, when I start the driver and look at the trace , I am getting the
following error

Trace:
-------------------------------------------------------------------------------------
16:14:04 DirXML Driver <.LDAP.driverset1.idm.services.system.META.>
requesting password.
16:14:04 LDAP ST:
DirXML Log Event -------------------
Driver: \META\system\services\idm\driverset1\LDAP
Status: Warning
Message: Code(-8001) Unable to retrieve application schema.
16:14:04 DirXML Driver <.LDAP.driverset1.idm.services.system.META.>
requesting password.
16:14:04 DirXML Driver <.LDAP.driverset1.idm.services.system.META.>
requesting password.
16:14:05 DirXML Driver <.LDAP.driverset1.idm.services.system.META.>
requesting password.
16:14:05 LDAP PT:Found supported entitlement "Account"
16:14:05 LDAP PT:localizing Account entitlement display name: de: User
16:14:05 LDAP PT:localizing Account entitlement display name: en: User
16:14:05 LDAP PT:Found supported entitlement "Group"
16:14:05 LDAP PT:localizing Group entitlement display name: de: Group
16:14:05 LDAP PT:localizing Group entitlement display name: en: Group
16:14:05 LDAP PT:Configuration still up-to-date. No update necessary.
16:14:05 LDAP PT:<entitlement-configuration modified="20091223104405">
<entitlements>
<entitlement
dn="CN=Account,CN=LDAP,CN=driverset1,dc=idm,dc=ser vices,dc=system"
resource-mapping="true" role-mapping="true">
<type>
<display-name>
<value langCode="de">User</value>
<value langCode="en">User</value>
</display-name>
</type>
</entitlement>
<entitlement
dn="CN=Group,CN=LDAP,CN=driverset1,dc=idm,dc=servi ces,dc=system"
resource-mapping="true" role-mapping="true">
<type>
<display-name>
<value langCode="de">Group</value>
<value langCode="en">Group</value>
</display-name>
</type>
</entitlement>
</entitlements>
</entitlement-configuration>
16:14:05 LDAP PT:
DirXML Log Event -------------------
Driver: \META\system\services\idm\driverset1\LDAP
Channel: Publisher
Status: Success
Message: Remote driver successfully started
16:14:05 LDAP PT:
DirXML Log Event -------------------
Driver: \META\system\services\idm\driverset1\LDAP
Channel: Publisher
Status: Success
16:14:05 LDAP PT:
DirXML Log Event -------------------
Driver: \META\system\services\idm\driverset1\LDAP
Channel: Publisher
Status: Success

16:14:06 LDAP ST:
DirXML Log Event -------------------
Driver: \META\system\services\idm\driverset1\LDAP
Channel: Subscriber
Status: Retry
Message: Code(-9006) The driver returned a "retry" status indicating
that the operation should be retried later. Detail from driver:
SubShim.execute(): Not connected to LDAP server or couldn't read its
schema.
16:14:06 LDAP ST:
DirXML Log Event -------------------
Driver: \META\system\services\idm\driverset1\LDAP
Channel: Subscriber
Status: Retry
Message: Code(-9006) The driver returned a "retry" status indicating
that the operation should be retried later. Detail from driver:
SubShim.execute(): Not connected to LDAP server or couldn't read its
schema.

--------------------------------------------------------------------------------

The authentication Id that I have given in the driver parameters is
having read access to schema. But still I m getting this error.

So, I tried to telnet the LDAP server from my i manager server. I got
the following reply.

metaserver1:~ # telnet xxxxxxxx xxxxxx
Trying xxxxxxxxxxx..
Connected to xxxxxxxxxxxxxx
Escape character is '^]'.
Connection closed by foreign host.

I am not sure what to do next . Please help me.

Thanks in advance


--
GopinathRao
------------------------------------------------------------------------
GopinathRao's Profile: http://forums.novell.com/member.php?userid=62050
View this thread: http://forums.novell.com/showthread.php?t=396629